You are here: 首頁 文章分類選單

飛朵啦學習手札

本網站建議使用Firefox2.0以上,或是使用Goole瀏覽器來瀏覽,並使用1024x768解析度來觀看.

飛朵啦學習手札

11

修補SSL Medium Strength Cipher Suites Supported (SWEET32)

E-mail 列印 PDF

弱點名稱:
SSL Medium Strength Cipher Suites Supported (SWEET32)

插件編號: 42873

風險程度: 中等

最近更新 ( 週五, 22 四月 2022 10:42 )
 
 
11

修補弱點SMB Signing not required

E-mail 列印 PDF

弱點名稱:
SMB Signing not required

插件編號: 57608

風險程度: 中等

最近更新 ( 週一, 11 四月 2022 11:22 )
 
 
11

修補弱點TLS Version 1.0 Protocol Detection

E-mail 列印 PDF

可以直接複製以下文字檔,存成TLSOff.reg,然後點兩下執行,執行完後,重新開機即可iis


Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.0]
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.0\Client]
"Enabled"=dword:00000000
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SecurityProviders\SCHANNEL\Protocols\TLS 1.0\Server]
"Enabled"=dword:00000000


 

最近更新 ( 週一, 11 四月 2022 11:20 )
 
13

在IIS 上使用 PHP CI

E-mail 列印 PDF

在網站的根目錄裡放置web.config,裡面內容如下:

<?xml version="1.0" encoding="UTF-8"?>
<configuration>
    <system.webServer>
        <rewrite>
            <rules>
                <rule name="Rewrite to index.php">
                    <match url="index.php|robots.txt|images|test.php" />
                    <action type="None" />
                </rule>
                <rule name="Rewrite CI Index">
                    <match url=".*" />
                    <conditions>
                        <add input="{REQUEST_FILENAME}" pattern="css|js|jpg|jpeg|png|gif|ico|htm|html" negate="true" />
                    </conditions>
                    <action type="Rewrite" url="index.php/{R:0}" />
                </rule>
            </rules>
        </rewrite>
    </system.webServer>
</configuration>  

如果放入後,執行網站有誤,那麼請安裝url-rewrite

參考來源:https://stackoverflow.com/questions/5408111/codeigniter-2-on-iis-with-web-config-file

 
十二28

Ubuntu 11.04 升级到 14.04.2 LTS

E-mail 列印 PDF

文章轉自:http://rongjih.blog.163.com/blog/static/33574461201551802140680/

升級成功很有效果

-----------------------

以下为Ubuntu 11.04的升级记录 (2015-06-18)。

由于11.04早就过了维护期,无法使用常规的升级方法!
》更新前:
$ uname -a
Linux bcserver4utest 2.6.38-8-server #42-Ubuntu SMP Mon Apr 11 03:49:04 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
》升级步骤记录:(参考:EOLUpgrades)2015-06-18
1)更改更新源
$ sudo cp /etc/apt/sources.list /etc/apt/sources.list.20150617.bak
$ sudo vi /etc/apt/sources.list
将内容改为如下:
deb http://old-releases.ubuntu.com/ubuntu/ natty main restricted universe multiverse
deb http://old-releases.ubuntu.com/ubuntu/ natty-updates main restricted universe multiverse
deb http://old-releases.ubuntu.com/ubuntu/ natty-security main restricted universe multiverse
deb http://old-releases.ubuntu.com/ubuntu/ natty-backports main restricted universe multiverse
deb http://old-releases.ubuntu.com/ubuntu/ natty-proposed main restricted universe multiverse
执行一下如下更新:
sudo apt-get update
$ sudo apt-get dist-upgrade
2)Update-manager
$ sudo aptitude install update-manager-core update-manager
3)更新内核
$ sudo aptitude install linux-image-server linux-headers-server
完成后重启一下 $ sudo reboot,内核更新后版本如下:
$ uname -a
Linux bcserver4utest 2.6.38-16-server #67-Ubuntu SMP Thu Sep 6 18:15:24 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
 
第 1 頁, 共 29 頁